[
Lists Home |
Date Index |
Thread Index
]
- From: james anderson <James.Anderson@mecomnet.de>
- To: David Megginson <david@megginson.com>
- Date: Fri, 07 Jan 2000 16:05:14 +0100
The following is true only of application which don't live very long. For
example, for processes which correspond to a single selfcontained document
only. Where the processes live longer and continue to process additional
documents over their life span, that second little
|| att.uri == ""
clause is going to make thier lives, and their coding, unnecessarily complicated.
In contrast with either of the illustrated clauses, i would expect a
standardized xml interface to support coding of the following sort.
static QName symFoo = sax?.??.intern("http://www.foo.com/ns/", "foo");
static QName symBar = sax?.??.intern("http://www.foo.com/ns/", "bar");
> for each att in atts do
>
> if att == symFoo
> doFoo(att.value)
> else if att == symBar
> doBar(att.value)
> end
> end
Anything else is looking for problems.
Yes, one could code this over a SAX which follows "option #2".
Why should each application, or application library, need to? Where's the benefit?
David Megginson wrote:
>
> "Simon St.Laurent" <simonstl@simonstl.com> writes:
>
> > Will SAX2 namespace processing take this 'real-world' approach (which I
> > totally support), or are there going to be options for this?
> >
> > It sounded earlier like you expect namespace processing to be the domain of
> > the parser, not the application, so it seems like a live issue.
>
> Basically, the difference in pseudo code is this:
>
> for each att in atts do
> if att.uri == "http://www.foo.com/ns/" || att.uri == ""
> if att.local == "foo"
> doFoo(att.value)
> else if att.local == "bar"
> doBar(att.value)
> end
> end
> end
>
> vs. this:
>
> for each att in atts do
> if att.uri == "http://www.foo.com/ns/"
> if att.local == "foo"
> doFoo(att.value)
> else if att.local == "bar"
> doBar(att.value)
> end
> end
> end
>
> In other words, there's not a very significant difference between the
> two. The main problem is that the spec is just so much harder to read
> and understand that it had to be.
>
xml-dev: A list for W3C XML Developers. To post, mailto:xml-dev@ic.ac.uk
Archived as: http://www.lists.ic.ac.uk/hypermail/xml-dev/ and on CD-ROM/ISBN 981-02-3594-1
To unsubscribe, mailto:majordomo@ic.ac.uk the following message;
unsubscribe xml-dev
To subscribe to the digests, mailto:majordomo@ic.ac.uk the following message;
subscribe xml-dev-digest
List coordinator, Henry Rzepa (mailto:rzepa@ic.ac.uk)
|