OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.

 


Help: OASIS Mailing Lists Help | MarkMail Help

 


 

   Encoding Problem

[ Lists Home | Date Index | Thread Index ]

Hi

<?xml version="1.0" encoding="UTF-8" ?>
<xsl:stylesheet xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="1.0">
<
xsl:variable name="home-link"> la maison</xsl:variable>
<
xsl:variable name="help-link">Aide</xsl:variable>
<
xsl:variable name="signout-link">Signe-Dehors</xsl:variable>
<
html>
<body>
<table>
<tr>
    <td width="36%" height="30" align="right" class="IconText">
        [<a href="Contents.asp" target="main" class="IconText">
            <b> <xsl:value-of select="$home-link"/> </b></a>] &#32;&#32;
        [<a href="default.asp?action=1" target="_top" class="IconText">
            <b> <xsl:value-of select="$signout-link"/> </b></a>]
    </td>
</tr>
</table>
</body>
</
html>
</
xsl:stylesheet>

when i try to transform this xsl with my xml packet to generate html ..... i can't see the desired results of
this "<xsl:variable name="home-link"> la maison</xsl:variable>" ,
I m having this result on my browser (IE 6) "?la maison"

i think this is a problem of encoding ..... i saved that xsl file as a UTF-8 ....
but when in browser i view source and again save the resultant html as a htm file with UTF-8 encoding and when i see this newly saved .htm file in browser it show me everythng fine

Plz Help





 

News | XML in Industry | Calendar | XML Registry
Marketplace | Resources | MyXML.org | Sponsors | Privacy Statement

Copyright 2001 XML.org. This site is hosted by OASIS