Lists Home |
Date Index |
Hi Michael and Peter,
Thanks for the quick feedback!
> I would go for something like "MusicXML.newFeature".
MusicXML doesn't use any namespaces aside from xml. We are using XML
1.0 DTD technology, and so far the lack of namespaces has not given us
any grief. So I am inclined to go with "new-feature" as the name.
(MusicXML names are all hyphenated rather than camel-cased.) That
keeps the PI name consistent with the element names.
What we really need to do is add a new attribute to an existing
element. In the absence of that attribute, In the absence of that
attribute, it's more compatible with existing software to represent
the data with a different element. The PI is basically saying "Even
though the following element is of one type, you need to alter the
interpretation to treat it more like this other element type." In the
past we've always been able to handle interim new features via
MusicXML's built-in extension elements, but that doesn't work here.
Just doing an exact match on the PI target rather than having to do
parsing of PI data certainly seems attractive.