OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.


Help: OASIS Mailing Lists Help | MarkMail Help

[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index]
Re: [xml-dev] XSLT Windows v's Unix

On 12/15/06, JackBrody <flannanbrody@hotmail.com> wrote:
> Hi
> I having a problem processing XSLT on unix at the moment, it works fine on
> windows but when I try process the same file on Unix I keep getting the same
> error. I'm wondering does anyone know is there a difference between the two
> operating systems that maay cause this problem....if so have you any
> solutions
> Most current operating systems have an XSLT processor installed. For
> example, Windows XP comes with the MSXML3 library, which includes an XSLT
> processor. Earlier versions may be upgraded and there are many alternatives,
> see the External Links section.
> Seems like JMeter is generating some dodgy XML, but not sure why that
> wouldn't fail on Windows also
> JMeter uses an XSLT file, jmeter-detail-report.xsl to transform the JMeter
> JTL output into a nicely formatted html table of results.
> The version of the file which I run with ant-jmeter (as a task in build.xml)
> runs well on Windows but fails on Unix with the following exception:
> [xslt] Processing /export/home/sfuser/sola/JMeter/JMeterResults.jtl to
> /export/home/sfuser/sola/JMeter/JMeterResults_detail.html
> [xslt] Loading stylesheet
> /export/home/sfuser/sola/JMeter/jmeter-results-detail-report.xsl
> [xslt] : Error! Content is not allowed in prolog.
> [xslt] : Error!
> com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is
> not allowed in prolog.
> [xslt] Failed to process /export/home/sfuser/sola/JMeter/JMeterResults.jtl
> /export/home/sfuser/sfv4-client/staging/sfv4client_jmeter.xml:132:
> javax.xml.transform.TransformerException:
> javax.xml.transform.TransformerException:
> com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: Content is
> not allowed in prolog.
> I tried removing spaces, changed the xml prolog in the xsl file, etc but it
> still doesn't work.
> Could you suggest what I can do to fix the problem?

You sometimes get this error when you've edited the XSLT using Windows
Notepad, which inserts a Byte Order Mark (BOM) into the file even
though its not encoded in UTF-16.  Try saving the file using a decent
editor and see if that helps, failing that post the bytes that consist
of the first few
characters in the file.

Also check out the "XSL-List" where questions like this crop up more often.


[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index]

News | XML in Industry | Calendar | XML Registry
Marketplace | Resources | MyXML.org | Sponsors | Privacy Statement

Copyright 1993-2007 XML.org. This site is hosted by OASIS