Re: [dita] Possible filename changes for DITA 1.0

From
Michael Priestley <>
Date
2005-03-14T21:29:00+00:00
ID
Thread
Re: [dita] Possible filename changes for DITA 1.0
MHonArc v2.5.0b2 -->

















dita message






[Date Prev]
 | [Thread Prev]
 | [Thread Next]
 | [Date Next]

--

[Date Index]
 | [Thread Index]
 | [List Home]








Subject: Re: [dita] Possible filename changes for DITA 1.0




From: Michael Priestley <>
To: Eric Sirois <>
Date: Mon, 14 Mar 2005 16:28:52 -0500




Seeing no objections, I'll make the
changes in the spec. 


Michael Priestley







Eric Sirois/Toronto/IBM@IBMCA

03/10/2005 09:45 PM




To



cc



Subject
[dita] Possible filename
changes for DITA 1.0








Hello fellow TC members,


Here is a subset of the proposed list of changes of file names for DITA

1.0.


Does not look like anyone found this one yet in the arch spec. -  pg.
36 in

the section 'Default nested topics entity' in the second paragraph needs
a

space

between thetopictype-info-types.


Kind regards,

Eric


topic_class.ent --> topicAttr.mod, topicAttr.xsd


topic_defn.ent --> topicDefn.ent  - remove underscore and camelCase
it

topic_grp.xsd  --> topicGrp.xsd  - remove underscore and camelCase
it


tbl_xml.mod --> tblDecl.mod, tblDecl.xsd  --- Decl for element
declarations

meta_xml.mod --> metaDecl.mod, metaDecl.xsd


ui-domain.mod --> uiDomain.mod uiDomain.xsd  - remove hyphen and
camelCase

it for the remaining domains.


Defn.ent and Grp.xsd files are essentially the same in terms of they serve

the same purpose.

They give us the capability to alias/substitute one element for another.


If we expand  Grp.xsd to Group.xsd the will be a conflict with

mapGroup.mod.  So we would have to find

a new name for mapGroup.xsd to avoid a conflict with mapGrp.xsd.


Changes that would affect the architecturalspec

  pg. 9 - tbl_xml.mod to tblDecl.mod

  pg. 9 - meta_xml.mod to metaDecl.mod


  pg.10 schema\concept.mod to conceptMod.xsd

  pg.11 schema\task.mod to taskMod.xsd

  pg.13 schema\reference.mod to referenceMod.xsd

  pg.13 ui-domain.mod to uiDomain.mod

           change remaining domains in the table.


  pg.18 mapgroup.mod to mapGroup.mod


  pg. 39 topic_mod.xsd to topicMod.xsd in the sample

  pg. 39 _mod.xsd and _grp.xsd to Mod.xsd and Grp.xsd

  pg. 39 concept_mod.xsd to conceptMod.xsd


  pg.40  concept_grp.xsd to conceptGrp.xsd

  pg.40  _grp.xsd to Grp.xsd

  pg.40 -domain.xsd to Domain.xsd




Eric A. Sirois

Staff Software Developer

DB2 Universal Database - DBA XML Tools Development

IBM Canada Ltd. - Toronto Software Lab

Email: 

Phone:(905) 413-2841

Blue Pages (Internal)


"Transparency and accessibility requirements dictate that public

information and government

transactions avoid depending on technologies that imply or impose a

specific product or

platform on businesses or citizens" - EU on XML-based office document

formats.










References:

Possible filename changes for DITA 1.0
From: Eric Sirois <>






[Date Prev]
 | [Thread Prev]
 | [Thread Next]
 | [Date Next]

--

[Date Index]
 | [Thread Index]
 | [List Home]