Hi Ernst Jan, thank you for your quick (and positive) response!
Freshly motivated I addressed the other topics of our last call (see recent version attached): Decouple names in semantic model and XML syntax: As far as I understood there is currently only the ID & IDREF elements in Base64Data that does not match the CamelCase naming scheme.
So I introduced the option to specify a 'modelName' attribute to each element if it deviates from the XML name.
For just these two elements I did not introduce an programmatic handling but added a sentence into the 'XML syntax' section comment.
See section 4.1.6 & 4.1.6.2 Making 'operations' more explicit: With the given 'feature' of arbitrary grouping I introduced a new 'operation' group and added a bitr opx explanatory comment to this new section (4.2.).
Is this a useful way to proceed or do we need additional mechanisms /restructurings?
Greetings, Andreas
> Hi, well, looks ok for now. You also mentioned the 'value' in Section
> 2.2.2 so hopefully it's clear. >
> Regards >
> Ernst Jan > >
> Andreas Kuehne wrote: >> Hi colleagues, >> >> >> I finally managed to build the mapping lists of XML & JSON name of >> elements that were really used within the spec. See the generated >> document attached. >> >> >> Some JSON names map to multiple XML names. This can be perfectly valid >> (e.g. 'msg' -> 'ResultMessage' and 'Message'). I updated the shady >> cases listed below: >> >> >> di: changed to 'dis' to map to DigestInfos >> >> result: changed to 'results' to map to VerifyManifestResults >> >> signedRef: changed to 'results' to map to VerifyManifestResult >> >> value: all JSON names should follow the same style. Renamed to 'val' >> >> IDREF: changed to 'idref' >> >> ID: problems with JAXB framework. Changing the JSON name to 'id' >> breaks the reference mechanism. Not changed. >> >> val: the lowercase 'value' was introduced to circumvent the 'mixed' >> attribute of the 'ds:TransformType'. The lowercase name was introduced >> for technically introduced elements. Does this provide any >> clarification for the user or is it just irritating? >> >> >> The XML to JSON mapping is one-to-one, no problems to fix here >> >> >> Greetings, >> >> >> Andreas >> >> -- >> Andreas Kühne >> phone: +49 177 293 24 97 >> mailto: >> >> Trustable Ltd. Niederlassung Deutschland Gartenheimstr. 39C - 30659 Hannover Amtsgericht Hannover HRB 212612 >> >> Director Andreas Kühne >> >> Company UK Company No: 5218868 Registered in England and Wales >> >> >>
---------------------------------------------------------------------
>> To unsubscribe from this mail list, you must leave the OASIS TC that >> generates this mail.
Follow this link to all your TCs in OASIS at: >> https://www.oasis-open.org/apps/org/workgroup/portal/my_workgroups.php >
--
Andreas Kühne phone: +49 177 293 24 97 mailto:
Trustable Ltd.
Niederlassung Deutschland Gartenheimstr.
39C - 30659 Hannover Amtsgericht Hannover HRB 212612 Director Andreas Kühne Company UK Company No: 5218868 Registered in England and Wales Attachment: dss-core-v2.0-18.06.18_16.13.19.docx Description: Binary data