Re: [ebxml-msg]

From
Arvola Chan <>
Date
2001-11-07T01:35:11+00:00
ID
058f01c1672c$1cb63650$
Thread
Re: [ebxml-msg]
David:

How about rephrasing the sentence on lines 1738-1739 as:

"For a reliably delivered message, TimeToLive MUST be greater than
(Timestamp + Retries * RetryInterval)."

I also agree with Dan that ExpirationTime would be a better name than
TimeToLive. However, that will trigger other requisite descriptive
changes because we currently have an errorCode named
TimeToLiveExpired.

Regards,
-Arvola

-----Original Message-----
From: David Fischer <>
To: Arvola Chan <>
Cc: ebXML Msg <>
Date: Tuesday, November 06, 2001 7:26 AM
Subject: [ebxml-msg]


Spec section 7.4.5:
TimeToLive MUST be greater than the product of Retries and RetryInterval
since
the message was originally sent.

Your comments:

  You cannot directly compare a dateTime quantity against a duration
quantity.

This does not directly compare.  TimeToLive is compared to (Retries *
RetryInterval) SINCE the message was originally sent.

I believe this is correct.  How would you prefer to say this?

Regards,

David Fischer
Drummond Group.



----------------------------------------------------------------
To subscribe or unsubscribe from this elist use the subscription
manager: <http://lists.oasis-open.org/ob/adm.pl>