← Prev in month ← Prev in thread
Next in thread → Next in month →

[OASIS Issue Tracker] (EBXMLMSG-52) Content-Disposition header requirement

From
OASIS Issues Tracker <>
Date
2014-07-11T12:33:20+00:00
ID
Thread
[OASIS Issue Tracker] (EBXMLMSG-52) Content-Disposition header requirement
Sander Fieten created EBXMLMSG-52:
-------------------------------------

             Summary: Content-Disposition header requirement
                 Key: EBXMLMSG-52
                 URL: https://issues.oasis-open.org/browse/EBXMLMSG-52
             Project: OASIS ebXML Messaging Services TC
          Issue Type: Bug
          Components: AS4 Profile
            Reporter: Sander Fieten


In section 5.1.9 support for use of the "Content-Disposition" MIME header and its "filename" parameter is required. 

A payload however does not necessarily have a file name. It is unclear how the header should be used in such case.

For exchanging such info it also is more logical to use the PartProperties element in the ebMS messaging header. 

The text also refers to "MIME specification (IETF) [RFC2045]". This RFC however does not mention this header. It is defined in RFC2183.
The MIME packaging used by AS4 (SwA) is defined in RFC2387 (MIME Multi-Part). Section 4 of that RFC discusses the use of the Content-Disposition header and recommends not to use this header unless handling of the filename parameter is explicitly specified. This is not the case in ebMS V3/AS4. 



--
This message was sent by Atlassian JIRA
(v6.2.2#6258)
← Prev in month ← Prev in thread
Next in thread → Next in month →