[ http://tools.oasis-open.org/issues/browse/OFFICE-3378?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=20894#action_20894 ]
Patrick Durusau commented on OFFICE-3378:
-----------------------------------------
Andreas,
I was reading "truncate" to mean "apply modulo 24." That is "truncate" was another name for "modulo 24" (for hours).
So is this what you are saying:
attribute value false: 48:00:00
attribute value true: 00:00:00
Noting that the attribute defaults to true.
Are you suggesting this is expected behavior?
> 19.367 number:truncate-on-overflow - meaning of modulo? - not well-defined? - see description
> ---------------------------------------------------------------------------------------------
>
> Key: OFFICE-3378
> URL: http://tools.oasis-open.org/issues/browse/OFFICE-3378
> Project: OASIS Open Document Format for Office Applications (OpenDocument) TC
> Issue Type: Bug
> Components: Part 1 (Schema)
> Affects Versions: ODF 1.2 CD 05
> Reporter: Patrick Durusau
> Fix For: ODF 1.2 CD 06
>
>
> We had a long discussion in http://tools.oasis-open.org/issues/browse/OFFICE-1689 about this attribute but missed the use of "modulo."
> From what I have found, for example:
> http://en.wikipedia.org/wiki/Modulo_operation
> http://mathworld.wolfram.com/ModularArithmetic.html
> http://www.cafeaulait.org/course/week2/15.html
> http://msdn.microsoft.com/en-us/library/se0w9esz%28VS.71%29.aspx
> So the remainder of 24 modulo 24 is 0.
> So the remainder of 48 modulo 24 is 0.
> So the remainder of 72 modulo 24 is 0.
> That can't be what we meant.
> Rather I think we meant to have the quotient plus any remainder.
> Yes?
> Apologies for missing this in our prior discussion. It seems so clear now.
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://tools.oasis-open.org/issues/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira