[ http://tools.oasis-open.org/issues/browse/OFFICE-3444?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=21554#action_21554 ]
Andreas Guelzow commented on OFFICE-3444:
------------------------------------------
From an implementors point of view there is really nothing more serious to discuss than this. The current draft defines a coordinate as just a numeric value, whether you call this a tuple or not is of less importance.
The proposed resolution now is to change this into a length (which is not just a numerical value but must carry a unit).
This is a huge and significant change.
I do realize that in ODF 1.0 we have:
<define name="coordinate">
<ref name="length"/>
</define>
with
<define name="length">
<data type="string">
<param name="pattern">-?([0-9]+(\.[0-9]*)?|\.[0-9]+)((cm)|(mm)|(in)|
(pt)|(pc)|(px))</param>
</data>
</define>
So the proposed resolution is to return to the definition of ODF 1.0. While this may be the right decision we really should not change our data types quite that easily.
> 18.3.9 coordinate should not be a tuple
> ---------------------------------------
>
> Key: OFFICE-3444
> URL: http://tools.oasis-open.org/issues/browse/OFFICE-3444
> Project: OASIS Open Document Format for Office Applications (OpenDocument) TC
> Issue Type: Bug
> Components: Graphics, Needs Discussion
> Affects Versions: ODF 1.2 CD 05
> Reporter: Andreas Guelzow
> Assignee: Patrick Durusau
> Priority: Blocker
> Fix For: ODF 1.2 CD 06
>
>
> 18.3.9 has been changed from "Like a length, except that the physical length denotes a certain point." to "A tuple of numeric values that defines a position."
> I don't think it makes sense to have a coordinate to be "a tuple". Shouldn't it just be a "A numeric value that describes a position"?
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://tools.oasis-open.org/issues/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira