Next in thread → Next in month →

RE: Core-19 schema comments

From
Hallam-Baker, Phillip <>
Date
2001-10-03T17:15:03+00:00
ID
Thread
RE: Core-19 schema comments
> >I would prefer an attribute group (i think). The use of inheritance
> 
> (Were you going to say more?)  Yeah, I struggled with which one to 
> recommend, and I could see using an attribute group too.  To date we 
> haven't used model groups or attribute groups, so I *suppose* 
> that would be 
> a reason for avoiding them, but if we really have no need for a 
> root-element semantic, then a group is fine.

Yeah, the use of inheritance seems to me to imply a semantic inheritance
that I don't think is appropriate.


> > > - Again regarding MajorVersion and MinorVersion, I thought we were
> > >    going to use facets to ensure that the integer is positive.  We
> > >    would want to make a VersionNumberType simple type for this.
> >
> >Sure, what does the schema look like?
> 
> Actually, I just checked, and there's already a built-in called 
> positiveInteger.  So you could use that directly.

Done


> So is your preferred naming scheme SingleAssertion etc.?  

Yeah, not particularly attached to the name but...

> >Done (although the outcome of the attributes discussion 
> might change this).
> 
> How would it do that?  I must be missing something obvious.

If we define the generic data slots there it would make sense to re-use
them since the application is pretty much the same.

> Yeah, this would be fairly substantial.  But we normally 
> favor element 
> content over attributes, so it seems odd to put "content" in 
> an attribute.

I'm not that bothered, but I try to avoid making changes
that affect the structure before I know that I won't be
undoing them again.

	Phill
Next in thread → Next in month →