At 01:57 PM 1/25/02 -0500, Scott Cantor wrote:
>Maybe (don't shoot me) it would be better to call it something other
>than AttributeNamespace? I think if you call something a namespace in
>the middle of an XML document, the confusion is fairly understandable.
>Then again, maybe it's a distinction without a difference, I don't know.
>The term AttributeNameQualifier came to mind.
I added prose in core 1.3.2, and also added a definition of "XML namespace"
to the glossary, to try to explain away the "SAML namespace" vs. "XML
namespace" distinction, but it's pretty awkward and confusing. I commented
on this back around F2F #2 at least, and would still love to change this
name (and also ActionNamespace), but had given up until emboldened by
Scott's recent comments. :-)
AttributeNameQualifier isn't too bad, but ActionValueQualifier doesn't work
quite as well. AttributeNameSet and ActionValueSet?
Eve
--
Eve Maler +1 781 442 3190
Sun Microsystems XML Technology Center eve.maler @ sun.com