Title: Message
There were in the 3.0.1 version - things like isReplacedBy, and so
forth. Using all lower case means that the word boundaries are no longer
distinguished: derivedfrom, entitykeyvalues and isreplacedby - making them
harder to read.
The canonicalisation algorithm already converts them to lowercase - why
would we need to do it to the keys?
I'm not in favour of anything that makes them harder to read, and that's
the effect of rendering them in all lower case. I wouldn't mind so much if
we reinstated the word boundaries using, for example, underscores; something
like: derived_from, entity_key_values, and is_replaced_by, would be OK, but
that changes the derived V2 keys. The capitalisation, on the other hand, doesn't
change the derived keys, which is one of the reasons I suggested it.
Still, I'd prefer that we had consistency. Having some in mixed case, and
some in all lowercase, is bad.
Tony
-----Original Message-----
From: Von Riegen,
Claus [mailto:]
Sent: Fri 11-Jun-04 20:23
To: Rogers, Tony;
Cc:
Subject: RE: [uddi-spec] Typos?
I
believe that we decided to convert all keys to lower case characters,
probably because of canonicalization. Are there any upper case characters left
in UDDI keys?
Claus
-----Original Message-----
From: Rogers, Tony
[mailto:]
Sent: Donnerstag, 10. Juni 2004
03:35
To:
Subject:
[uddi-spec] Typos?
I just happened to notice that the UDDI v3 keys for:
uddi:uddi.org:categorization:derivedfrom
and
uddi:uddi.org:categorization:entitykeyvalues
are all lower-case,
which is inconsistent with the other canonical tModel keys. Should they
really be:
uddi:uddi.org:categorization:derivedFrom
and
uddi:uddi.org:categorization:entityKeyValues
?
While I'm at it, there's a more serious question:
uddi:uddi.org:categorization:validatedBy
should probably be:
uddi:uddi.org:identifier:validatedBy
to be consistent with
uddi:uddi.org:identifier:isReplacedBy
But I suspect we won't be too keen on making that change because it
breaks things. Changing the case of derivedFrom and entityKeyValues
shouldn't break things because case isn't significant in comparing UDDI keys
- it won't even change the derived V2 keys, because they must be mapped to
lowercase before being digested.
Thoughts?
Tony Rogers