Re: [virtio-dev] Re: [virtio] [RFC PATCH 1/3] notifications: unify notifications wording in core

From
Paolo Bonzini <>
Date
2018-04-11T13:11:27+00:00
ID
Thread
Re: [virtio-dev] Re: [virtio] [RFC PATCH 1/3] notifications: unify notifications wording in core
On 11/04/2018 14:55, Cornelia Huck wrote:
>>> Nice, I think the cleanup is worthwhile.  
>> I agree.  I wondered if we should use the term "used buffer interrupt"
>> and "available buffer notification".  In the common case I think it
>> would be clearer, though there are cases such as vhost-pci where the
>> roles are swapped.
>
> If it is swapped in some cases, it is bound to cause confusion for
> those. I'd vote for using "notification" in both cases, as this patch
> is doing.

Fair enough!  I think I agree myself. :)

Paolo