On Thu, Aug 22, 2019 at 01:23:45PM +0200, Cornelia Huck wrote:
> On Tue, 13 Aug 2019 14:13:19 +0100
> Stefan Hajnoczi <> wrote:
> > +\item[\field{num_queues}] is the total number of request virtqueues exposed by
> > + the device. Each virtqueue offers identical functionality and there are no
> > + ordering guarantees between requests made available on different queues.
> > + Use of multiple queues is intended to increase performance.
>
> As this came up during review of the qemu implementation of the device:
> num_queues is not the number of virtqueues of the device, but rather
> the number of request queues -- which is clear from the description,
> but not from the field name. Maybe rename this field to
> num_request_queues or so?
Sounds good. Will fix in the next revision.
> > +\subsubsection{Device Operation: Request Queues}\label{sec:Device Types / File System Device / Device Operation / Device Operation: Request Queues}
> > +
> > +The driver enqueues normal requests on an arbitrary request queue. High
> > +priority requests are not placed on request queues. The device processes
> > +requests in any order. The driver is responsible for ensuring that ordering
> > +constraints are met by making available a dependent request only after its
> > +prerequisite request has been used.
> > +
> > +Requests have the following format with endianness chosen by the driver as
>
> "chosen by the driver in the FUSE_INIT request used to initiate the
> session", maybe? You describe this below, but I think it would be
> easier to understand if you mentioned it here already.
Thanks, will fix in the next revision.