← Prev in month
← Prev in thread
Next in thread →
Next in month →
[wsrp-wsia] Minutes for 12 December 2002 Meeting
<best viewed in courier> Minutes for WSRP-WSIA Meeting 12/12/2002 WSRP Members In Attendance: Abdelnur, Alejandro Sun No Aickin, Sasha Plumtree Yes Atkinson, Olin Novell Yes Blich, Amir SAP Yes Braun, Chris Novell Yes Brooks, Rex Starbourne Yes Clegg, Dave Sybase No Cox, T. J. Novell Yes Cox, William BEA Yes Dirking, Brian Stellent Yes Drye, Stephen Art Technology Yes Dynin, Jane Plumtree No Filicetti, Gino Bowstreet No Freedman, Michael Oracle Yes Hillerman, Mike Peoplesoft No Jacob, Richard IBM Yes Jones, Timothy CrossWeave No Klien, Jon Reed-Elsivier No Kramer, Andre Citrix Yes Kropp, Alan Epicentric Yes Leue, Carsten IBM Yes Martin, Monica Drake Certivo Yes Mitsuoka, Madoka Fujitsu No Nolen, Adam Reed-Elsivier Yes Palas, Petr Moravia IT Yes Pugsley, Ken Peoplesoft No Ramesh, Raj CommerceOne No Randhawa, Sunit Fujitsu Yes Ratcliffe, Nigel Factiva No Reshef, Eilon WebCollage No Rudnicki, Joe U.S. Navy Yes Shumaker, Gennady SAP Yes Smith, Steven Capitol College Yes Stanko, Joseph Plumtree No Tayar, Gil WebCollage Yes Thompson, Rich IBM Yes Tmari, Yossi SAP Portals Yes van Lydegraf, Eric Kinzan Yes Wiecha, Charles IBM Yes Young, Michael Plumtree Yes Prospective Members: Allamaraju, Subrahmanyam BEA Yes Machak, Dan Tibco No (Q: should I be reporting WSIA members who are not WSRP members?) 27 of 40 members attended the meeting. Meeting started at 11:03am EST Last weeks minutes were accepted. Rich went over the issues left over from last week: #154 Rename "entity" to "portlet" Resolved: rename "entity" to "portlet entity" (matches JSR168). No objections #163 Restructure performInteraction and performBlockingInteraction Resolved: Since UpdateResponse contains a superset of the fields in InteractionResponse, replace those fields with one that is of type InteractionResponse. No objections. #164 An entity SHOULD support help, and CAN support edit Resolved: Drop verbage about supporting optional modes of windows state. No objections. #155 Rename 'FAULT' entityStateChange flag Resolved: Rename field "entityState" No objections #184(no number at meeting time)can performInteraction return new navigationalState? Raised by Gil. Discussion about if it is a non-blocking action. Not having the navigationalstate can force some existing portals into a bad environment. Entity developer needs the navigationalstate returned. Gil will assign an issue numnber. NOT Resolved. #165 The Consumer should not strip the namespace prefix from form parameters Long discussion. This is tied to issue #179 about roles, which needs to be resolved first. NOT Resolved. #166 Remove the section on load balancing Resolution: Incorporate the ideas of this section in the Introduction and drop the section. No objections. #167 userContextID should not be a required field Resolution: Make userContextID nillable. Revisit after looking at roles. No objections. #168 Make wsrp-navigationalState required Resolution: Yes. If missing then the new state is the empty string. Make consistent with interaction calls. No objections. #169 Does refresh page (F5/Ctrl+R) re-invoke performBlockingInteraction? Discussion about it being Consumer specific in the current draft. Should it be in the draft? NOT Resolved. #173 Add summary of interfaces in beginning of interface chapters Discussion about adding a new chapter between current chapters 3 and 4. Rich will add proposal on email. NOT Resolved. Thomas brought up that we have only 3 Thursday meetings before the next face-to-face and 3-4 large issues. Next meeting we will work on the minor issues and identify the major issues. 2 January work on Registration and Roles 7 and 9 January (Tuesday and Thursday) will be 2 hour meetings. Gil is looking for comments on the primer. Meeting ended 12:23pm EST -Steven
← Prev in month
← Prev in thread
Next in thread →
Next in month →