← Prev in month
← Prev in thread
Next in thread →
Next in month →
[wsrp] Public Review Comment: Confusion due to reuse of the word "resource"
As part of a search through the spec for places that might need updates if we move toward gR() specific structures, I noticed that we reuse the word resource in three different ways; 1) to refer to a portlet-referenced resource; 2) to refer to a localization of a string and 3) to refer to some generic entity. I suspect this will result in some confusion for first time readers and would therefore recommend we change the last usage to other appropriate synonyms (the first two are already embedded solidly in the reserved/defined terms of WSRP v1). Based on my search, I would recommend the following changes: 1.3: resource -> item 3.4/Enduring: delete "resource" 3.4/Transient: resource -> item 3.6: Rewrite in terms of "WSRP Leasing" and referred to leased items rather than resources 5.1.5: delete "resource" from intro text 5.1.25: resource -> item 6.1.1: resource -> item 6.1.4: resource -> item 6.1.20: resource -> item (all but wsrp:resourceSuspended) 6.6: resource -> item 7.2: resource -> item; "registration resource" -> "registration" 7.4: resource -> item 8.4: resource -> item 8.8: resource -> item 10.3: resource -> item 14: resource -> item (1st instance) Appendix C (Session state): "resource handling" -> "processing" Rich
← Prev in month
← Prev in thread
Next in thread →
Next in month →