Next in thread →
Next in month →
Re: [xliff-omos] locQualityIssue id
Done! - Robert On Nov 26, 2018, at 8:50 AM, David Filip <> wrote: Robert, Phil, all 2 issues WRT the Localization Quality Issue ids. 1) There should be no id on locQualityIssue, singular, the individual entry.. they are NOT referencable individually either in XLIFF 2.1 or in ITS 2.0. Having the individual ids would cause a data model disparity. @Robert van Engelen would you please remove the id from this one? 2) Great that we now have the id on locQualityIssues, plural, the array wrapper However, this id is not the regular XLIFF id which is an NMToken. This one comes from ITS 2.0 that reuses the xml:id which is stricter, i.e. NCName @Robert van Engelen would you please create the NCName type and use for this id? NCnames will satify NMToken but -- on top of NMToken restrictions -- MUST NOT start with numbers and MUST NOT contain colons. Although this is the only NCName occurrence to my knowledge s far, I think this should be generalized same as the NMtoken type.. Cheers dF Dr. David Filip =========== Convenor, JTC 1/SC 42/WG 3 Trustworthiness of AI | National mirror chair, NSAI TC 02/SC 18 AI | Head of the Irish national delegation, ISO/IEC JTC 1/SC 42 AI | Chair & Editor, OASIS XLIFF OMOS TC | Secretary & Lead Editor, OASIS XLIFF TC | NSAI expert to ISO/IEC JTC 1/SC 38 Cloud Computing, ISO TC 37/SC 3 Terminology management, SC 4 Language resources, SC 5 Language technology Moravia Research Fellow ADAPT Centre KDEG, Trinity College Dublin Mobile: +420-777-218-122 On Sat, Nov 24, 2018 at 3:27 PM Robert van Engelen <> wrote: Hi Phil, Please fetch commit d899655 with the latest changes, see the diffs: https://github.com/oasis-tcs/xliff-omos-jliff/commit/d8996559a57c1f2b8c53af852d44a08d9bf13314#diff-b89ba9003dca25e3d00f69ed10fdb1bf The BLUE part is what I changed in the schema to add the id property: "locQualityIssues": { "description": "A standoff wrapper element to group any number of single issue elements related to the same span of source or target content", "type": "object", "properties": { "id": { "$ref": "#/definitions/NMTOKEN" }, "items": { "type": "array", "items": { "$ref": "#/definitions/locQualityIssue" }, "minItems": 1 } }, "additionalProperties": false, "required": [ "items" ] }, The locQualityIssue type had its id property added some time ago, so I left it untouched. Thanks. - Robert Dr. Robert van Engelen, CEO/CTO Genivia Inc. On Nov 22, 2018, at 11:35 AM, Phil Ritchie <> wrote: Robert Thanks for the commit but despite your explanation below it looks like you have added the id property to the contained locQualityIssueâs instead of the wrapper. <image001.png> Phil Phil Ritchieâ Chief Technology Officer | Vistatec Vistatec House, 700 South Circular Road,Kilmainham, Dublin 8, Ireland. Tel: +353 1 416 8000 | Direct: +353 1 416 8024 Email: www.vistatec.com | ISO 9001 | ISO 13485 | ISO 17100 | ISO 27001 Think Global Vistatec Ltd. Registered in Ireland 268483. Registered Office, Vistatec House, 700, South Circular Road, Kilmainham. Dublin 8. Ireland.The information contained in this message, including any accompanying documents, is confidential and is intended only for the addressee(s). âThe unauthorized use, disclosure, copying, or alteration of this message is strictly forbidden. If you have received this message in error please notify the sender immediately. From: Robert van Engelen <> Sent: Tuesday 13 November 2018 17:13To: Phil Ritchie <>Cc: XLIFF OMOS TC <>Subject: Re: [xliff-omos] locQualityIssue id Phil et al. The JLIFF 2.1 schema in the GitHub repo is updated to include the id property on locQualityIssue. Quoting David: JLIFF the id should be on the wrapper array This means we need an object that wraps the array. The object will contain the id property and an array property: "its_locQualityIssues": { "description": "A standoff wrapper element to group any number of single issue elements related to the same span of source or target content", "type": "object", "properties": { "id": { "$ref": "#/definitions/NMTOKEN" }, "items": { "type": "array", "items": { "$ref": "#/definitions/its_locQualityIssue" }, "minItems": 1 } }, "additionalProperties": false, "required": [ "items" ] }, The property name for the the array âitemsâ is somewhat arbitrary. Any ideas for a better name? - Robert Dr. Robert van Engelen, CEO/CTO Genivia Inc. voice: (850) 270 6179 ext 104 fax: (850) 270 6179 mobile: (850) 264 2676 LinkedIn: www.linkedin.com/in/robertvanengelen/ On Nov 5, 2018, at 12:46 PM, Phil Ritchie <> wrote: I think we need locQualityIssue to have an id property. Otherwise I see no way to reference an individual issue within an array of locQualityIssues when using standoff. Phil Ritchieâ Chief Technology Officer | Vistatec Vistatec House, 700 South Circular Road,Kilmainham, Dublin 8, Ireland. Tel: +353 1 416 8000 | Direct: +353 1 416 8024 Email: www.vistatec.com | ISO 9001 | ISO 13485 | ISO 17100 | ISO 27001 Think Global Vistatec Ltd. Registered in Ireland 268483. Registered Office, Vistatec House, 700, South Circular Road, Kilmainham. Dublin 8. Ireland.The information contained in this message, including any accompanying documents, is confidential and is intended only for the addressee(s). âThe unauthorized use, disclosure, copying, or alteration of this message is strictly forbidden. If you have received this message in error please notify the sender immediately.
Next in thread →
Next in month →