RE: [xliff-omos] locQualityIssue id

From
Phil Ritchie <>
Date
2018-11-22T16:35:38+00:00
ID
Thread
RE: [xliff-omos] locQualityIssue id
Robert

 

Thanks for the commit but despite your explanation below it looks like you have added the id property to the contained locQualityIssueâs instead of the wrapper.

 

 

Phil

 

Phil Ritchie​

Chief Technology Officer | Vistatec

Vistatec House, 700 South Circular Road,
Kilmainham, Dublin 8, Ireland.

Tel: +353 1 416 8000 | Direct: +353 1 416 8024

Email: 

www.vistatec.com | ISO 9001 | ISO 13485 | ISO 17100 | ISO 27001

Think Global

Vistatec Ltd. Registered in Ireland 268483. Registered Office, Vistatec House, 700, South Circular Road, Kilmainham. Dublin 8. Ireland.
 The information contained in this message, including any accompanying documents, is confidential and is intended only for the addressee(s). 
âThe unauthorized use, disclosure, copying, or alteration of this message is strictly forbidden. 
If you have received this message in error please notify the sender immediately.

From: Robert van Engelen <>

Sent: Tuesday 13 November 2018 17:13

To: Phil Ritchie <>

Cc: XLIFF OMOS TC <>

Subject: Re: [xliff-omos] locQualityIssue id

 

 

Phil et al.

 

The JLIFF 2.1 schema in the GitHub repo is updated to include the id property on locQualityIssue.

 

Quoting David:

 

JLIFF the id should be on the wrapper array

 

This means we need an object that wraps the array. The object will contain the id property and an array property:

 

    "its_locQualityIssues": {

      "description": "A standoff wrapper element to group any number of single issue elements related to the same span of source or target content",

      "type": "object",

      "properties": {

        "id": { "$ref": "#/definitions/NMTOKEN" },

        "items": {

          "type": "array",

          "items": { "$ref": "#/definitions/its_locQualityIssue" },

          "minItems": 1

        }

      },

      "additionalProperties": false,

      "required": [ "items" ]

    },

 

The property name for the the array âitemsâ is somewhat arbitrary. Any ideas for a better name?

 

- Robert

 

  Dr. Robert van Engelen, CEO/CTO Genivia Inc.

  voice: (850) 270 6179 ext 104

  fax: (850) 270 6179

  mobile: (850) 264 2676

  LinkedIn: 
www.linkedin.com/in/robertvanengelen/

  

 

On Nov 5, 2018, at 12:46 PM, Phil Ritchie <> wrote:

 

I think we need locQualityIssue to have an id property. Otherwise I see no way to reference an individual issue within an array of locQualityIssues when using standoff.

 

Phil Ritchieâ

Chief Technology Officer

 | 

Vistatec

Vistatec House, 700 South Circular Road,

Kilmainham, Dublin 8, Ireland.

Tel: 

+353 1 416 8000

 | 

Direct: 

+353 1 416 8024

Email: 



www.vistatec.com

 | 

ISO 9001

 | 

ISO 13485

 | 

ISO 17100

 | 

ISO 27001

Think Global

Vistatec Ltd. Registered in Ireland 268483. Registered Office, Vistatec House, 700, South Circular Road, Kilmainham.
 Dublin 8. Ireland.

The information contained in this message, including any accompanying documents, is confidential and is intended only for the addressee(s). 

âThe unauthorized use, disclosure, copying, or alteration of this message is strictly forbidden. 

If you have received this message in error please notify the sender immediately.