[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: [OASIS Issue Tracker] Updated: (OFFICE-3444) NEEDS-DISCUSSION18.3.9 coordinate should not be a tuple
[ http://tools.oasis-open.org/issues/browse/OFFICE-3444?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]
Andreas Guelzow updated OFFICE-3444:
-------------------------------------
Summary: NEEDS-DISCUSSION 18.3.9 coordinate should not be a tuple (was: 18.3.9 coordinate should not be a tuple)
Description:
18.3.9 has been changed from "Like a length, except that the physical length denotes a certain point." to "A tuple of numeric values that defines a position."
I don't think it makes sense to have a coordinate to be "a tuple". Shouldn't it just be a "A numeric value that describes a position"?
was:
18.3.9 has been changed from "Like a length, except that the physical length denotes a certain point." to "A tuple of numeric values that defines a position."
I don't think it makes sense to have a coordinate to be "a tuple". Shouldn't it just be a "A numeric value that describes a position"?
If we say "A length that describes a position." why do we need to have this data type at all? We should just be using length. The data type need not (should not?) include a statement about what the data is used for.
@Patrick: do we ever use this to specify a pair or triple etc.? If we do then we need to specify how the components are separated: by whitespace, semicolon?
> NEEDS-DISCUSSION 18.3.9 coordinate should not be a tuple
> --------------------------------------------------------
>
> Key: OFFICE-3444
> URL: http://tools.oasis-open.org/issues/browse/OFFICE-3444
> Project: OASIS Open Document Format for Office Applications (OpenDocument) TC
> Issue Type: Bug
> Components: Graphics
> Affects Versions: ODF 1.2 CD 05
> Reporter: Andreas Guelzow
> Assignee: Patrick Durusau
> Priority: Blocker
> Fix For: ODF 1.2 CD 06
>
>
> 18.3.9 has been changed from "Like a length, except that the physical length denotes a certain point." to "A tuple of numeric values that defines a position."
> I don't think it makes sense to have a coordinate to be "a tuple". Shouldn't it just be a "A numeric value that describes a position"?
--
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://tools.oasis-open.org/issues/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira
[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]