[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: [OASIS Issue Tracker] (OSLCCCM-27) New type ChangeAuthorization needed for CM spec
[ https://issues.oasis-open.org/browse/OSLCCCM-27?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=62839#comment-62839 ]
James Amsden commented on OSLCCCM-27:
-------------------------------------
Maybe what we're missing is the notion of authorization to do work to address a ChangeRequest. This could apply to any ChangeRequest: requests (defect, enhancement) or tasks (task and review task). This seems orthogonal to the notion of ChangeRequest, and not a different kind of ChangeRequest.
Would adding:
ChangeRequest authorizedBy Person.
address your need? This could have the typical parent/child meaning - child tasks aren't authorized unless the containing parent task is authorized. The notion of authorization to perform a task is the setting of the authorizedBy property. Tools could use subscription notifications and queries to notify people of and display authorized change requests.
> New type ChangeAuthorization needed for CM spec
> -----------------------------------------------
>
> Key: OSLCCCM-27
> URL: https://issues.oasis-open.org/browse/OSLCCCM-27
> Project: OASIS OSLC Lifecycle Integration for Change and Configuration Management (OSLC CCM) TC
> Issue Type: Bug
> Components: Change Management
> Reporter: Martin Sarabura
>
> Notwithstanding issue #26 which I just posted, I feel that change notice should be added explicitly to the spec.
> There are two classes of type in the current spec: Request and Task.
> Requests include Change Request (which is also drawn up as the base type in the UML diagram), Enhancement and Defect.
> Tasks include Task (which is drawn up as the base type in the UML diagram) and ReviewTask.
> A change notice in certain tools is neither a request nor a task: It is an authorization to perform multiple tasks. Thus it is more of a "command" than a request and it is a container of tasks. Since it has a different meaning than the available Types and since it is found in a number of CM tools, I believe it should be listed as its own type.
--
This message was sent by Atlassian JIRA
(v6.2.2#6258)
[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]