oslc-promcode — archive
[Date Prev]
| [Thread Prev]
| [Thread Next]
| [Date Next]
— [Date Index]
| [Thread Index]
| [Month Index]
| [List Home]
Fw: [oslc-promcode] Version Control Commit by f-jiang
Funakoshi-san, Here are the changes we discussed last meeting: Replace the class promcode:Measure with ems:Measure. ems:Measure is therefore an external class, like foaf:Person. ems:Measure has the following properties: - dcterms:title, which corresponds to promcode:title - ems:metric, which corresponds to promcode:typeOfMeasure - ems:unitOfMeasure, which corresponds to promcode:unitOfMeasure - ems:numericValue, which corresponds to promcode:value Replace the class MeasureType with ems:Metric Replace the class UnitType with ems:UnitOfMeasure
Replace the property promcode:observes with ems:observes (this links promcode:Measurement to ems:Measure). Yes, the range of promcode:determines is ems:Measure. No, do not replace promcode:Measurement by ems:Measurement at this time. They are very similar, but ems:Measurement is not an exact match for PROMCODE. However, even if we did adopt ems:Measurement it is OK to add more properties like promcode:measures. The list of properties we use goes into the Resource Shape that PROMCODE provides for each resource type. RDF is different than OO design in this respect. Leave promcode:measures as is. Also, I suggest the following name change. Rename promcode:typeOfScopeItemSize to promcode:scopeItemSizeMetric. This links promcode:Project to ems:Metric. We can be more precise here because ems:Metric has a subclass ems:SizeMetric. The range of promcode:scopeItemSizeMetric is ems:SizeMetric. We could add a subclass arrow from ems:SizeMetric to ems:Metric in the Domain Model diagram. _________________________________________________________ Arthur Ryman, PhD Distinguished Engineer
Master Inventor
Academy of Technology Chief Data Officer, Application Platform IBM Systems
Middleware 905.413.3077 (phone)
416.939.5063 (cell)
IBM InterConnect 2015
From:
Kazuhiro Funakoshi <[email protected]>
To:
Arthur Ryman/Toronto/IBM@IBMCA, "[email protected]" <[email protected]>
Date:
01/28/2015 03:05 AM
Subject:
RE: [oslc-promcode] Version Control Commit by f-jiang Sent by:
<[email protected]>
If I understand correctly, we have following changes for shapes: * remove Measure and Measurement resources
- and simply forget about MeasureType and UnitType as they were out of domain scope * use ems:metric instead of typeOfScope (Project?MeasureType) * change the range of unitOfScopeItemSize to ems:UnitOfMeasure * change the range of determines to ems:Measure They are trivial, but one question is: * What should we do for promcode:measures?
- originally Measurement?Artifact and going to be ems:Measurement? promcode:Artifact. Can we really add this for resource defined in ems?
- or define an inverted relation as promcode:Artifact?ems:Measurement ?
- or define as inheritance promcode:Measurement <: ems:Measurement ?
[Date Prev]
| [Thread Prev]
| [Thread Next]
| [Date Next]
— [Date Index]
| [Thread Index]
| [Month Index]
| [List Home]