[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: [OASIS Issue Tracker] (TOSCA-207) postconfigure operation on Standard operation should be renamed in poststart
[ https://issues.oasis-open.org/browse/TOSCA-207?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=52441#comment-52441 ]
Moshe Elisha commented on TOSCA-207:
------------------------------------
The possibilities are:
1. Leave things as they are:
tosca.interfaces.node.lifecycle.Standard:
create
configure
start
postconfigure
stop
delete
This makes the "postconfigure" operation name confusing as according to the docs it runs after the "start" operation and not after the "configure" operation.
2. Rename the operation to "post_start":
tosca.interfaces.node.lifecycle.Standard:
create
configure
start
post_start (was postconfigure)
stop
delete
This makes the name a lot more clearer but I don't see a real value here if the "post_start" always runs after the "start" and there is no way to intervene. The user can just place the content of the "post_start" in the "start".
3. I propose to leave it "post_configure" but run it between the "post_configure" and the "start":
tosca.interfaces.node.lifecycle.Standard:
create
configure
post_configure
start
stop
delete
This has value in case the node has a relationship. In that case the order (on a certain node) will be:
Standard.create
Configure.pre_configure_[source/target]
Standard.configure
Configure.post_configure_[source/target]
Standard.post_configure
Standard.start
Standard.stop
Standard.delete
This allows the user to have one more point to manipulate the deploy time execution.
I think this has the most value.
> postconfigure operation on Standard operation should be renamed in poststart
> ----------------------------------------------------------------------------
>
> Key: TOSCA-207
> URL: https://issues.oasis-open.org/browse/TOSCA-207
> Project: OASIS Topology and Orchestration Specification for Cloud Applications (TOSCA) TC
> Issue Type: Bug
> Components: Profile-YAML
> Reporter: Luc Boutier
>
> postconfigure:
> description: Standard lifecycle post-configure operation (post-start)
> That will be much more clear (simple if it was called poststart as this is actually a poststart operation).
--
This message was sent by Atlassian JIRA
(v6.2.2#6258)
[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]