[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: Re: [virtio-comment] Comments on Virtio 1.0 cs03
On Tue, Feb 16, 2016 at 11:50:55AM +0200, Michael S. Tsirkin wrote:
> On Mon, Jan 11, 2016 at 02:54:14PM +0800, Kevin Lo wrote:
> > Hi,
> >
> > After reading the specification, I have two minor comments.
> >
> > First, sort device status field [1] in the section 2.1 to improve readability,
> > namely ACKNOWLEDGE (1), DRIVER (2), DRIVER_OK (4), FEATURES_OK (8),
> > DEVICE_NEEDS_RESET (64), FAILED (128).
>
> The order is inconsistent, but I think it's more important to
> list them in the order they are set, since we say above it:
> The \field{device status} field provides a simple low-level
> indication of the completed steps of this sequence.
>
> So a better order is ACKNOWLEDGE, DRIVER, FEATURES_OK, DRIVER_OK,
> FAILED, DEVICE_NEEDS_RESET since need reset would typically
> be set only on error after DRIVER_OK.
Okay, that makes sense to me.
> I'll send a patch that does this.
Cool, thanks.
> > Second, since vring* and VRING* have been replaced with virtq* and VIRTQ*
> > respectively, I suggesting renaming the header virtio_ring.h to virtio_queue.h
> > or fixing include guards to match the name of the header.
>
> Good idea.
>
> > [1] http://docs.oasis-open.org/virtio/virtio/v1.0/cs03/virtio-v1.0-cs03.html#x1-90001
> >
> > Thanks,
> > Kevin
[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]