[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]
Subject: Suggested improvement for virtq_need_event
In virtio_queue.h, virtq_need_event is implemented as
static inline int virtq_need_event(uint16_t event_idx, uint16_t
new_idx, uint16_t old_idx)
{
return (uint16_t)(new_idx - event_idx - 1) < (uint16_t)(new_idx
- old_idx);
}
. Wouldn't the equivalent
static inline int virtq_need_event(uint16_t event_idx, uint16_t
new_idx, uint16_t old_idx)
{
return (uint16_t)(event_idx - old_idx) < (uint16_t)(new_idx - old_idx);
}
be more readable/intuitive (and possibly slightly faster and more compact)?
Apologies for bikeshedding!
[Date Prev] | [Thread Prev] | [Thread Next] | [Date Next] -- [Date Index] | [Thread Index] | [List Home]