virtio — archive
[Date Prev]
| [Thread Prev]
| [Thread Next]
| [Date Next]
— [Date Index]
| [Thread Index]
| [Month Index]
| [List Home]
Comments on Virtio 1.0 cs03
Hi,
After reading the specification, I have two minor comments.
First, sort device status field [1] in the section 2.1 to improve readability,
namely ACKNOWLEDGE (1), DRIVER (2), DRIVER_OK (4), FEATURES_OK (8),
DEVICE_NEEDS_RESET (64), FAILED (128).
Second, since vring* and VRING* have been replaced with virtq* and VIRTQ*
respectively, I suggesting renaming the header virtio_ring.h to virtio_queue.h
or fixing include guards to match the name of the header.
[1] http://docs.oasis-open.org/virtio/virtio/v1.0/cs03/virtio-v1.0-cs03.html#x1-90001
Thanks,
Kevin
[Date Prev]
| [Thread Prev]
| [Thread Next]
| [Date Next]
— [Date Index]
| [Thread Index]
| [Month Index]
| [List Home]