xacml — archive
[Date Prev]
| [Thread Prev]
| [Thread Next]
| [Date Next]
— [Date Index]
| [Thread Index]
| [Month Index]
| [List Home]
Re: [xacml] Style modifications to combining algorithms
On 3 September, Tim Moses writes: [xacml] Style modifications to combining algorithms
> 1. The name of the function is "Policy", rather than > "denyOverridesRuleCombiningAlgorithm", etc.. This is because we talk about
> evaluating a "Policy", rather than evaluating the combining algorithm. ....
> Here is the resulting definition. All the best. Tim. >
> Decision Policy(Rule rule[]) > { I think all the changes except the first one are good. However, I think we "evaluate" a particular combining algorithm in order to reach a Decision for a Policy. If the algorithm is named "Policy", then there is no way to distinguish which particular combining algorithm is being used. So I prefer retaining the names containing "CombiningAlgorithm" and the specific algorithm name, such as "DenyOverrides", as the name of the combining algorithm. Anne
--
Anne H. Anderson
Email: [email protected]
Sun Microsystems Laboratories 1 Network Drive,UBUR02-311
Tel: 781/442-0928
Burlington, MA 01803-0902 USA
Fax: 781/442-1692
[Date Prev]
| [Thread Prev]
| [Thread Next]
| [Date Next]
— [Date Index]
| [Thread Index]
| [Month Index]
| [List Home]