← Prev in month ← Prev in thread

Abstract parameter names

From
Ray Denenberg, Library of Congress <>
Date
2009-09-16T14:45:38+00:00
ID
115c01ca36dc$53d937d0$
Thread
Abstract parameter names
What is the purpose of abstract parameters?  I think one of the prime 
purposes is that they will be well-known and recognized within a template.

For example, if I say  &query={searchTerms}  in a template in an openSearch 
description file the client knows stick the query into a "query" parameter. 
I think this is the essence of an abstract parameter.

However we have named our abstract parameter for the query, "query", not 
"searchTerms".

We discussed this, quite awhile ago, I remember the discussion, it sounded 
good at the time, but the fact is that if we want a browser, like Firefox, 
who already has provided some OpenSearch support, to ever pick up on what we 
are doing, I think we need to give our abstract parameters the same name 
that OpenSearch does.  Firefox recognizes "searchTerms".

startIndex is another OpenSearch parameter that we have given a different 
name to: startPosition.  And some others.

Should we consider renaming these to correspond to OpenSearch?  It's not too 
late. (But it will be soon.)

--Ray
← Prev in month ← Prev in thread