> From: Ray Denenberg, Library of Congress [mailto:]
>
> What is the purpose of abstract parameters? I think one of the prime
> purposes is that they will be well-known and recognized within a
template.
I don't think that is their purpose. They are abstract concepts that
can be bound to concrete implementations. A template would be part of a
binding.
> However we have named our abstract parameter for the query, "query",
not
> "searchTerms".
That's because OpenSearch doesn't support queries, but we do.
> We discussed this, quite awhile ago, I remember the discussion, it
sounded
> good at the time, but the fact is that if we want a browser, like
Firefox,
> who already has provided some OpenSearch support, to ever pick up on
what
> we
> are doing, I think we need to give our abstract parameters the same
name
> that OpenSearch does. Firefox recognizes "searchTerms".
And our binding to OpenSearch will use searchTerms, and will explain how
it relates to the abstract concept of a query.
> startIndex is another OpenSearch parameter that we have given a
different
> name to: startPosition. And some others.
I believe the semantics of the two are identical and don't have a
problem changing it, but don't see a reason to either.
> Should we consider renaming these to correspond to OpenSearch? It's
not too
> late. (But it will be soon.)
I'd say "No".
Ralph