RE: [xml-dev] Namespace terminology

From
Evan Lenz <>
To
Lars Marius Garshol <>,
Date
2002-02-05T21:04:37Z
ID
<>
Thread
RE: [xml-dev] Namespace terminology
Lars Marius Garshol wrote:
> I've run into a slightly odd problem. I am describing some event-based
> XML APIs that do namespace processing and represent processed
> qualified names either as "namespaceuri localname" strings, or as
> ("namespaceuri", "localname") tuples[1].
>
> The question is, what do I call these things?

I like the term used by the XPath 1.0 spec: "expanded-name" (or, depending
on your naming convention of choice, "expanded_name", etc.)

There's no ambiguity there unlike other options such as XSDL's "QName".

Evan