OASIS Mailing List ArchivesView the OASIS mailing list archive below
or browse/search using MarkMail.

 


Help: OASIS Mailing Lists Help | MarkMail Help

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

IMHORe: Can XPointers be used as a name (was Re: RDDL for names ? (wasRe: XMLSchema built-in data typenamespaceURI.))



An XPointer can be used as either a name or an address depending on the
form. The raw name form is a name, the child sequence form is an address and
the full form may combine characteristics of both. e.g.

<xsd:simpleType name="unsignedInt" id="unsignedInt">..

http://www.w3.org/2000/10/XMLSchema#unsignedInt  is a perfectly good name
(IMHO)

.../xsd:simpleType[@name='unsignedInt'] is also an fine name (IMHO)


suppose this

<div id="foo">
    <rddl:resource xl:role=".../XMLSchema#simpleType"
                            xm:href="...bar.xsd#foo_simpleType" ...
    <rddl:resource xl:role="..../XMLSchema#element"
                            xl:href="...bar.xsd#foo_element ...
    <rddl:resource xl:role=".../XMLSchema#attribute"
                            xl:href="...bar.xsd#foo_attribute" ...
</div>

and

<schema>
    <simpleType name="foo" id="foo_simpleType">...
    <element name="foo" id="foo_element"> ...
    <attribute name="foo" id="foo_attribute">...

now the QName "bar:foo" and the URI ref: "...#foo" not only match but using
RDDL indirection this single URI is mapped to different URIs depending on
the type (simpleType,element,attribute)

The complex XPointer stuff is a red herring, a raw name is a perfectly good
XPointer as well. It is just in the general case if you don't wish to use
ids then full XPointers can fill in.

-Jonathan

Eric van der Vlist wrote:
> We are again on the same old slippery slope!
>
> Using URIs as names is fine but ambiguous...
>
>
> What we need is the ability to define a unique unambiguous name for each
> type (and probably for each of the W3C XML Schema construct) and since I
> don't believe we can impose a single scheme to construct these names, I
> think that using an attribute with a uri reference would be the most
> practical solution:

see above.

>
> <xsd:simpleType name="myUnsignedInt"
> uri="http://dyomedea.com/ns/types/myUnsignedInt" ...
>

An id directly maps to an unambiguous URI but is simpler (and importantly al
ready in the XML Schema spec)

-Jonathan
>
> --
> Rendez-vous à Paris pour net2001.               http://www.mynet2001.net
> ------------------------------------------------------------------------
> Eric van der Vlist       Dyomedea                    http://dyomedea.com
> http://xmlfr.org         http://4xt.org              http://ducotede.com
> ------------------------------------------------------------------------