[
Lists Home |
Date Index |
Thread Index
]
At 04:07 PM 6/2/2002 -0400, Glenn Marcy wrote:
>In reading this thread main thing that I see confusing people
>is the name of the parameter "qName". I remember when it was
>first something like "rawName", which wasn't as well aligned
>with terms in the Namespace spec. However, it was perhaps a
>slightly less confusing name with Namespaces turned off. The
>"dual nature" of the methods in the interface are unfortunate.
I've been thinking about this unfortunate situation and think I may have a
proposal which will let us steer through the disconnect between
namespaces-on and namespace-off approaches as people like Glenn seem to see
them.
How about:
1) The qName parameter is renamed "rawName", and documentation explains
that this is both the Qualified Name in namespace-aware processing and the
Name in namespace-unaware processing. I don't believe that changing
parameter names in Java has any direct impact on code built on those
parameter names - overriding methods can rename parameters at their
convenience. (I could be wrong about that, of course.)
2) A filter which copies rawName to localName in the event that localName
is empty or null is included in the org.xml.sax.helpers package. This way,
developers can adapt filters and applications which work using
namespace-aware expectations to namespace-unaware processing without having
to retrofit their code.
Effectively this is a fix-through-documentation and supplements, though
admittedly it touches the code.
Simon St.Laurent
"Every day in every way I'm getting better and better." - Emile Coue
|